[LINUX/JAVA] Corrigindo Failed to load JavaHL Library – ECLIPSE

Toda vez que eu abri o meu eclipse aparecia a seguinte mensagem.

linux ubuntu subeclipse erro libsvn-java
linux ubuntu subeclipse erro libsvn-java

Quando um certo dia tentei abrir o meu eclipse e o mesmo travou por diversas vezes e não consegui a abrir de jeito nenhum. Toda vez que meu eclipse da este erros de travamentos eu simplesmente vou e apago a pasta oculta .metadata contida no meu workspace e ele volta, só que todas a minhas configurações vão para o espaço.

Hoje acordei sem preguiça e resolvi, que solucionaria da melhor forma sem ter que remover a pasta metadata.

Então entrei na pasta metadata a primeira coisa que fiz foi abrir o arquivo .log contido no interior desta pasta, foi quando para minha supresa estava o seguinte log
!ENTRY org.eclipse.core.resources 2 10035 2012-10-04 09:43:03.379
!MESSAGE The workspace exited with unsaved changes in the previous session; refreshing workspace to recover changes.

!ENTRY org.tigris.subversion.clientadapter.javahl 1 0 2012-10-04 09:43:10.631
!MESSAGE Failed to load JavaHL Library.
These are the errors that were encountered:
no libsvnjavahl-1 in java.library.path
no svnjavahl-1 in java.library.path
no svnjavahl in java.library.path
java.library.path = /usr/lib/jvm/java-6-openjdk-i386/jre/lib/i386/client:/usr/lib/jvm/java-6-openjdk-i386/jre/lib/i386::/usr/java/packages/lib/i386:/usr/lib/i386-linux-gnu/jni:/lib/i386-linux-gnu:/usr/lib/i386-linux-gnu:/usr/lib/jni:/lib:/usr/lib
!SESSION 2012-10-04 09:45:02.083 ———————————————–
eclipse.buildId=M20120208-0800
java.version=1.6.0_24
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Framework arguments: -product org.eclipse.epp.package.jee.product
Command-line arguments: -os linux -ws gtk -arch x86 -product org.eclipse.epp.package.jee.product

Como pode ver existe 2 erros ou 2 !ENTRY cada uma seguida de uma !MESSAGE sendo que a primeira informa que o eclipse foi encerrado e não salvo algumas configurações, já a segunda a mais importante no nosso caso informa que houve falha ao carregar a biblioteca JavaHL.

Para resolver este problema basta executar o seguinte comando no console do linux
sudo apt-get install libsvn-java

E seus problemas serão resolvidos.

Abraço galera espero ter ajudado.

Anúncios

Um comentário sobre “[LINUX/JAVA] Corrigindo Failed to load JavaHL Library – ECLIPSE

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s